Service Outage
Incident Report for Fleek
Resolved
The issue causing slow loading times for the app and some customer sites, related to one of our upstream providers, has been resolved.

All services are now functioning as expected. If you encounter any further issues, please don't hesitate to reach out to us at support@fleek.xyz.

Thank you for your understanding and patience as we worked through this.
Posted Jan 07, 2025 - 14:30 UTC
Investigating
We are currently experiencing an issue causing slow loading times for the app and some customer sites. This appears to be related to an issue with one of our upstream providers.

Our team is actively investigating and working to restore normal performance as quickly as possible.

We sincerely apologize for the inconvenience and appreciate your patience. Please check back here for updates as we work to resolve this issue.
Posted Jan 07, 2025 - 13:30 UTC
This incident affected: Applications UI (Fleek App).